cFos speed test is woefully low on my 1Gb/1Gb FIOS connection

Post new topic   Reply to topic

View previous topic View next topic Go down

Re: cFos speed test is woefully low on my 1Gb/1Gb FIOS connection

Post by cFos Chris on Wed Aug 23, 2017 8:59 am

cFosSpeed dynamically adjusts RWIN and SG optimizer doesn't know that. so, their analysis is wrong.
avatar
cFos Chris
cFos Moderator
cFos Moderator

Anzahl der Beiträge : 6
Anmeldedatum : 2017-06-23
Ort : Bonn, Germany

View user profile http://cfos.de

Back to top Go down

Re: cFos speed test is woefully low on my 1Gb/1Gb FIOS connection

Post by cFos Chris on Wed Aug 23, 2017 8:56 am

If you calibrate by hand (i.e. do up and downloads), don't use cfosspeed's calibration, since it will delete all calibration data so far.

please do first some downloads that fully use your line, some 1-2 minutes are fine. then do some uploads for some minutes. does this lead to a better calibration result?
avatar
cFos Chris
cFos Moderator
cFos Moderator

Anzahl der Beiträge : 6
Anmeldedatum : 2017-06-23
Ort : Bonn, Germany

View user profile http://cfos.de

Back to top Go down

Re: cFos speed test is woefully low on my 1Gb/1Gb FIOS connection

Post by streetwolf on Wed Aug 23, 2017 1:16 am

Hi...

Could you please look at my post below and comment on the items that are in BOLDQuestion

Is my RWIN value too high for my 940/940 Mbps connection?
What about the RWIN value not being a multiple of MSS?

I ran the SG TCP Optimizer BDP calculator and the only way I got near the RWIN value below is if I set Bandwidth to 940 Mbps and Delay to 1065ms. There is no way I have delays this high. Delays are usually from 1-300 ms. So is something wrong with your RWIN resizing?
avatar
streetwolf
Newbies
Newbies

Anzahl der Beiträge : 5
Anmeldedatum : 2017-08-11

View user profile

Back to top Go down

Re: cFos speed test is woefully low on my 1Gb/1Gb FIOS connection

Post by streetwolf on Fri Aug 18, 2017 1:39 am

This is from the Speedguide.net TCP Analyzer.  RWIN is kind of large.  Your thoughts please.

TCP options string = 020405b40103030b0101040222020101
MTU = 1500
MTU is fully optimized for broadband.
MSS = 1460
Maximum useful data in each packet = 1460, which equals MSS.
Default TCP Receive Window (RWIN) = 125220864
RWIN Scaling (RFC1323) = 11 bits (scale factor: 2^11=2048)
Unscaled TCP Receive Window = 61143

In Windows 10, unless "TCP/IP Auto-Tuning" is disabled, only the Current TCP Window is displayed. Use the latest TCP Optimizer for tweaking.
RWIN seems to be an excessively large number. If you're on a line lower than 20 Mbps (that is not satellite), consider using a smaller value.
For optimum performance, consider changing RWIN to a multiple of MSS.
Other RWIN values that might work well with your current MTU/MSS:
64240  (up to 2 Mbit lines, depending on latency. MSS * 44)
128480 (1-5 Mbit lines, depending on latency. MSS * 44 * 2)
256960 (2-14 Mbit lines, depending on latency. MSS * 44 * 2^2)
513920 (8-30 Mbit lines, depending on latency. MSS * 44 * 2^3)
1027840 (25-60 Mbit lines depending on latency. MSS * 44 * 2^4)
bandwidth * delay product (Note this is not a speed test):

Your TCP Window limits you to: 5008835 kbps (626104 KBytes/s) @ 200ms
Your TCP Window limits you to: 2003534 kbps (250442 KBytes/s) @ 500ms
MTU Discovery (RFC1191) = ON
Time to live left = 48 hops
TTL value is ok.
Timestamps (RFC1323) = OFF
Selective Acknowledgements (RFC2018) = ON
IP type of service field (RFC1349) = 00000000 (0)


Last edited by streetwolf on Wed Aug 23, 2017 1:20 am; edited 1 time in total
avatar
streetwolf
Newbies
Newbies

Anzahl der Beiträge : 5
Anmeldedatum : 2017-08-11

View user profile

Back to top Go down

Re: cFos speed test is woefully low on my 1Gb/1Gb FIOS connection

Post by martin on Wed Aug 16, 2017 7:36 am


nice!

Yes, however this happens only if you are using near maximum bandwidth or the remote server is far (in terms of ping time) away. In this case RWIN is changed because of the RWIN expansion feature:
https://www.cfos.de/en-us/cfosspeed/rwin-expansion.htm
avatar
martin
cFos Moderator
cFos Moderator

Anzahl der Beiträge : 15
Anmeldedatum : 2017-06-23

View user profile

Back to top Go down

Re: cFos speed test is woefully low on my 1Gb/1Gb FIOS connection

Post by streetwolf on Mon Aug 14, 2017 7:24 pm

I ran the calibration using the FIOS server located in NYC and now the calibration is 100% (perfect).

If I choose not to use traffic shaping will my RWIN value still change and will this still be a performance booster for my speeds?


Speed Info
Version 10.22.2290
Windows Name Windows 10 Pro Multiprocessor Free (8 procs)
Windows Version 10.00.15063 (x64)
Maximum Raw Send Speed 127.4 mbytes/s
Maximum Acked Send Speed 127.4 mbytes/s
Maximum Receive Speed 125.2 mbytes/s
Minimum Delay 3 ms
Delay Variance Fixed to 3 ms
Current Maximum Receive Speed 124.4 mbytes/s
Current Maximum Send Speed 127.3 mbytes/s
Traffic Counting Method adaptive
Pinger udp_km5
MTU Limit 65535 (65535) bytes
Averager Time 4 s
Total Raw Sent Volume 30.07 gbytes
Total Acked Sent Volume 29.24 gbytes
Total Received Volume 41.56 gbytes
Total Time Used 24h 8m
Inhibit Bridged No
Maximum IP Length 1500 bytes
Pings Sent 11,119
Pongs Received 10,360 (93.1%)
Current Send Speed 131.9 mbytes/s
Send Delay 10-14 ms
Receive Delay 5-5 ms
Calibration Done 100% (Perfect)
Traffic Shaping Status shaping is active
avatar
streetwolf
Newbies
Newbies

Anzahl der Beiträge : 5
Anmeldedatum : 2017-08-11

View user profile

Back to top Go down

Re: cFos speed test is woefully low on my 1Gb/1Gb FIOS connection

Post by martin on Mon Aug 14, 2017 8:11 am


Yes, it's not ideal that our server is in Europe. Therefore I would recommend you just do several big uploads / downloads simultaneously againt some server of you choice (near you). This should calibrate it.
avatar
martin
cFos Moderator
cFos Moderator

Anzahl der Beiträge : 15
Anmeldedatum : 2017-06-23

View user profile

Back to top Go down

Re: cFos speed test is woefully low on my 1Gb/1Gb FIOS connection

Post by streetwolf on Fri Aug 11, 2017 1:02 pm

I've recalibrated many times using the cFos speedtest and now it's at 20% (poor).  Where is the server located that is used for the speed test?  Based on my abysmal results I suspect it might be in Europe while I'm near New York City (USA).  Also the data sizes that are used for the tests are quite low for my ~1Gb connection.  So far cFosSpeed hasn't done anything for me.  I might have to ask for a refund if I can't get things sorted out.

btw... Is the cFos speed test the only way to calibrate?
avatar
streetwolf
Newbies
Newbies

Anzahl der Beiträge : 5
Anmeldedatum : 2017-08-11

View user profile

Back to top Go down

Re: cFos speed test is woefully low on my 1Gb/1Gb FIOS connection

Post by martin on Fri Aug 11, 2017 8:02 am


your calibation is a 0%. You need to calibrate the line first. Do several full bandwith uploads and downloads simultaneously, so cFosSpeed can calibrate.
avatar
martin
cFos Moderator
cFos Moderator

Anzahl der Beiträge : 15
Anmeldedatum : 2017-06-23

View user profile

Back to top Go down

cFos speed test is woefully low on my 1Gb/1Gb FIOS connection

Post by streetwolf on Fri Aug 11, 2017 1:03 am

The FIOS speed test gives me about 920/950 with a ping of 5ms..  CFos speed test gives me an absolutely abysmal result.  Have you coded the program to allow for 1Gb connections?  Is it the server I'm connected to?  IS there a server closet to me like New York City?

Speed Info
Version 10.22.2290
Windows Name Windows 10 Pro Multiprocessor Free (8 procs)
Windows Version 10.00.15063 (x64)
Maximum Raw Send Speed 5797 kbytes/s
Maximum Acked Send Speed 5797 kbytes/s
Maximum Receive Speed 3076 kbytes/s
Minimum Delay 3 ms
Delay Variance 2 ms
Current Maximum Receive Speed 3076 kbytes/s
Current Maximum Send Speed 5797 kbytes/s
Traffic Counting Method adaptive
Pinger udp_km5
MTU Limit 65535 (65535) bytes
Averager Time 4 s
Total Raw Sent Volume 404.6 mbytes
Total Acked Sent Volume 258.6 mbytes
Total Received Volume 82.06 mbytes
Total Time Used 17m 55s
Inhibit Bridged No
Maximum IP Length 1500 bytes
Pings Sent 478
Pongs Received 452 (94.5%)
Current Send Speed 134.2 mbytes/s
Send Delay 10-17 ms
Receive Delay 20-27 ms
Calibration Done 0% (Poor)
Traffic Shaping Status shaping is active

FIOS Speed Test Results.

avatar
streetwolf
Newbies
Newbies

Anzahl der Beiträge : 5
Anmeldedatum : 2017-08-11

View user profile

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You can reply to topics in this forum