cFos Software Forum
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Program list missing again 2456

Go down

Program list missing again 2456 Empty Re: Program list missing again 2456

Post by Lloyd Dunamis on Sun Oct 18, 2020 4:14 am

Drool wrote:
In the meantime, I've disabled these updates in the hope my settings.ini won't get overwritten (Options > Program updates > Automatically update settings.ini).
Oh. Actually forgot this is a thing.

Well, since I've turned it off as suggested, it has not broken the settings.ini nor my internet connection so far.
Thanks for reminding us about this auto-update feature.
Program list missing again 2456 0slVf2e

Hopefully it does get fixed soon (so we get the latest shaping rules; though even w/o having the latest shaping rules, the installer-provided settings should still work very well anyway).

Lloyd Dunamis
Newbies
Newbies

Anzahl der Beiträge : 3
Anmeldedatum : 2020-09-29

Back to top Go down

Program list missing again 2456 Empty Re: Program list missing again 2456

Post by Eficiente on Wed Oct 14, 2020 6:43 am

Drool wrote:Today I discovered this bug too. v11.04.

Recently I'd been experiencing slow browsing while doing heavy downloading. I ignored it 'til today when I looked at cFosSpeed and noticed the Programs and Protocols lists were completely empty.

A fresh reinstall (uninstall, reboot, deleted config in ProgramData and AppData, install, reboot again) brough them back. Then they soon disappeared again!

Noticing the small settings.ini and its contents - it looks like it's being overwritten with some XML content:

https://pastebin.com/LSCBtRkp

My guess is, cFosSpeed is periodically looking for a new default settings.ini online, and dumping the wrong result into that file. My further guess is, there's a lot of people with b0rked default program and protocol settings who don't realise it.

In the meantime, I've disabled these updates in the hope my settings.ini won't get overwritten (Options > Program updates > Automatically update settings.ini).

Hope this gets fixed in the next release.

Thx you this fixed my problem too.

Eficiente
Newbies
Newbies

Anzahl der Beiträge : 1
Anmeldedatum : 2020-10-01

Back to top Go down

Program list missing again 2456 Empty Re: Program list missing again 2456

Post by Drool on Tue Oct 13, 2020 2:55 am

Today I discovered this bug too. v11.04.

Recently I'd been experiencing slow browsing while doing heavy downloading. I ignored it 'til today when I looked at cFosSpeed and noticed the Programs and Protocols lists were completely empty.

A fresh reinstall (uninstall, reboot, deleted config in ProgramData and AppData, install, reboot again) brough them back. Then they soon disappeared again!

Noticing the small settings.ini and its contents - it looks like it's being overwritten with some XML content:

https://pastebin.com/LSCBtRkp

My guess is, cFosSpeed is periodically looking for a new default settings.ini online, and dumping the wrong result into that file. My further guess is, there's a lot of people with b0rked default program and protocol settings who don't realise it.

In the meantime, I've disabled these updates in the hope my settings.ini won't get overwritten (Options > Program updates > Automatically update settings.ini).

Hope this gets fixed in the next release.

Drool
Newbies
Newbies

Anzahl der Beiträge : 4
Anmeldedatum : 2019-04-10

Lloyd Dunamis likes this post

Back to top Go down

Program list missing again 2456 Empty Re: Program list missing again 2456

Post by Lloyd Dunamis on Fri Oct 02, 2020 7:51 am

Welp there it goes again.

...Turning off then on the WiFi seems to trigger it sometimes...?

After restoring the settings.ini, turning off-on the WiFi again seems to apply the restored traffic shaping rules.
Which I guess makes sense, since cFos prolly needs initiation on the internet connection.

I have to wonder how this would happen on ethernet connected computers then. Loose or accidental cable disconnection?


Sample of the AllDefault in Current Connections window, for reference/visual.
Program list missing again 2456 MuaVpaR


(EDIT) Perhaps not specifically on/off of WiFi that triggers it, but something about Windows 10 and the internet/WiFi adapter?
My internet has been disappearing for a moment, while other devices in the same network do not. As I checked the settings.ini, it became 3KB instead of the default 54KB.
Comparing the contents, the broken one is not even a proper .ini file anymore:
Program list missing again 2456 EuVRXjE


Last edited by Lloyd Dunamis on Mon Oct 05, 2020 12:05 am; edited 1 time in total (Reason for editing : Another speculation/observation, and broken settings.ini sharing)

Lloyd Dunamis
Newbies
Newbies

Anzahl der Beiträge : 3
Anmeldedatum : 2020-09-29

Back to top Go down

Program list missing again 2456 Empty Re: Program list missing again 2456

Post by glennb2 on Tue Sep 29, 2020 11:44 pm

Lloyd Dunamis wrote:Just the default list of programs upon installation are deleted ("\ProgramData\cFos\cFosSpeed\settings.ini"). Any programs added that weren't in the default list were still there. Regardless, traffic shaping is borken due to not having said rules.
In the Current Connections screen, all connections will show as "Default", and changing the priorities temporarily reverts it back to default.
I'm either getting the behavior you describe or the protocols overriding application specific profiles. I run the software on 4 machines (3 on release version and one on latest beta) and I haven't been able to track down what triggers either behavior. My windows version is newer however: Windows 10 20H2

Minor bugs I can live with but core functionality of the software is affected with this bug...

glennb2
Newbies
Newbies

Anzahl der Beiträge : 2
Anmeldedatum : 2020-09-20

Back to top Go down

Program list missing again 2456 Empty Re: Program list missing again 2456

Post by Lloyd Dunamis on Tue Sep 29, 2020 4:13 pm

v11.04.2440 here, and it happens on my Win10 1803 laptop and Win7 SP1 desktop, too.

Just the default list of programs upon installation are deleted ("\ProgramData\cFos\cFosSpeed\settings.ini"). Any programs added that weren't in the default list were still there. Regardless, traffic shaping is borken due to not having said rules.
In the Current Connections screen, all connections will show as "Default", and changing the priorities temporarily reverts it back to default.

At first I thought it was just due to a bad shutdown, but it doesn't happen on every bad shutdown, and it still happens sometimes with proper shutdowns.

Once the settings.ini has been restored with the settings from the installer, it will need a system restart, and just restarting the program and the service couldn't apply the restored settings.

Lloyd Dunamis
Newbies
Newbies

Anzahl der Beiträge : 3
Anmeldedatum : 2020-09-29

glennb2 likes this post

Back to top Go down

Program list missing again 2456 Empty Re: Program list missing again 2456

Post by iPooPaLot on Fri Sep 25, 2020 5:47 pm

I´m having this issue too (latest beta). Program list is empty but also the protocols list.

iPooPaLot
Newbies
Newbies

Anzahl der Beiträge : 5
Anmeldedatum : 2019-08-15

GlopGlop31 likes this post

Back to top Go down

Program list missing again 2456 Empty Re: Program list missing again 2456

Post by tin_yeuk on Mon Sep 14, 2020 9:12 am

I am getting this issue as well, this is definitely a major issue. This bug wipes out all the programs in the list, and prioritization stops working, something seriously has crashed!

tin_yeuk
Newbies
Newbies

Anzahl der Beiträge : 21
Anmeldedatum : 2020-07-11

GlopGlop31 and iPooPaLot like this post

Back to top Go down

Program list missing again 2456 Empty Program list missing again 2456

Post by RamboNTanga on Sun Sep 13, 2020 10:29 am

Program list is missing again in the latest beta and priorization does not seem to apply for programs in that list even when added manually.

RamboNTanga
Newbies
Newbies

Anzahl der Beiträge : 33
Anmeldedatum : 2019-11-20

GlopGlop31, iPooPaLot and tin_yeuk like this post

Back to top Go down

Program list missing again 2456 Empty Re: Program list missing again 2456

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You can reply to topics in this forum